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Adding a Signature to a Report

Last Modified on 08/03/2023 4:54 pm EDT

Version 20.2

n Note: Before adding a signature to a report, you will need toscan a signature and link it to a provider.

Adding a Signature to a Report

Note: The steps below won't work for billing statement reports (found in the Billing_Rpts folder), chart reports, or

prescription reports. If you need a signature added to either of these types of reports, contact Office Practicum Support.

Joining the DRLABEL table

Before we can add a signature, we have to add the signature data field to selected fields.

. Select Tools > OP Reports.

. Locate the report where you would like to add a signature.
. Right-click on the desired report and selectDesign mode.
. Click the Data tab at the top of the window.
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5. The window on the data tab represent database query. It controls which tables of the database are connected to the

report, and what fields on those tables are selected.
6. Click the SQL button.

7. Click the Tables tab to modify the tables selected for the report.

Tables Fields | [ calcs | }3 Search | " Group | F:] Group Search |%l Sort | @ saL |

Available Tables

8. A Query Designer window will pop up displaying all of the tables used in Office Practicum. At the bottom of the window,
the selected tables are displayed. Look to see if the DRLABEL table is in the list of selected tables. If so, skip to the next
section. If not, we need to add it. Find the DRLABEL in the list of available tables.
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¢ DRLABEL DRLABEL
B TCATEGORY

DTM_CATEGORY_LIMDTM_CATEGORY LIl
DTN_DIAG_TEST_MDTM_DIAG_TEST_Mi
DTM_LAB DTM_LAB

DTMN_MASTER _DETADTM_MASTER_DETA
DTM_OFL_DETAIL [DTM_OFL_DETAIL
DTN_OP_FORM_LIS DTM_OP_FORM_LIS
DTM_OP_FORM_LIS'DTM_OP_FORM_LIS

Selected Tables
Table | Table Mame | SQL Alias Join Type
Register REGISTER. REGISTER._1

9. Double-click it to add it to selected tables. A Join Table window will appear.
10. Set the Join Type toLeft Outer.

Join Table
Join DRLABEL Table with
IRag\ster ;I
DRLABEL Fiel Register Fields
[sorG ~ PATNO ~
HEADING LNAME
SIGNAME FNAME
DRADD Add ML
TAXIDNO BIRTHDAT
PHONENO Remove | [SEX
LICNO PORGFNM
DEANO PORGLNM
SERVNG A PORGMI >
loined Fields
DRLABEL Field Operator ~
DRLABEL LNAME = REGISTER_LLNAME
DRLABEL FNAME = REGISTER_LFNAME
DRLABEL ADDRESS = REGISTER_L.ADDRESS
DRLABEL .CITY = REGISTER_L.CITY ©
< >

oK Cancel

11. Next, we need to set the table we are joining to. Choose the REGISTER table from the combo box.

Join DRLABEL Table with
IRegister ;I

12. If applicable, remove all suggested joins from the Joined Fields list box by selecting them and clicking the
Remove button. These suggestions are usually not correct.

Join Table H
Join Type Join DRLABEL Table with
Left Outer ~ Register -
DRLABEL Fields Register Fields

Joined Fields

DRLABEL Field

[DRLABEL.ADDRESS REGISTER,
[DRLABEL.CITY REGISTER,
DRLABEL.STATE REGISTER.
[DRLABEL.ADDR ID

13. Alist of fields for the DRLABEL table appears on the left side of the window. LocateADDR ID from this list.
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Join Type Join UHLASEL | 30Ie with
Inner ;I Register ;I
DRLABEL Fields Reqister Fields

PRACTICE MAME

TYPEPROVIDER Femave | PAT REF BY

FIELDSTR 1 IMM REGISTRY OK

FIELDSTR2 PORTAL LOGIN

FIELDINT1 7 PORTAL PASSWORD ~
Joined Fields

14. Alist of fields for the joining table appears on the right side of the window. Select ADDR_ID.
15. Click the Add button to add it to the list of joined fields.

Join Table H

Join Type Join DRLABEL Table with
Jiemer K| -
DRLABEL Fields Register Fields

PRACTICE NAME “ DOD A
MISC1 VOID NOTE

ACTIVESTATUS ADDR. ID

ADDR ID Add P ADDR ID

TAXONOMYID 5 ADDR ID

TYPEPROVIDER Remove | |PATREF BY

FIELDSTR1 MM REGISTRY OK

FIELDSTR2 PORTAL LOGIN

FIELDINT L h PORTAL PASSWORD ¢
oined Fields

DRLABEL Field Operator

DRLABEL.ADDR ID = Register. ADDR 1D

oK Cancel

16. Click OK to close the window.
17. The DRLABEL table should now appear in the list of selected tables on the Query Designer window.

Joining the GRAPHICS table
Check if the GRAPHICS table is in the list of selected tables. If so, skip to the next section. If not, we need to add it.

1. Select the Tables tab in the Query Designer Window.
2. Find the GRAPHICS table in the list of available tables and double click to add it. A Join Table window will pop up.

GET_MEW_SETRX  GET_NEW_SETRX
GETLABRESULTS ~ GETLABRESULTS
GLOBAL_PREFEREN(GLOBAL_PREFEREN
GROWTH_CHART  GROWTH_CHART
GROWTHCHART — GROWTHCHART
GROWTHCHART LM GROWTHCHART LIV
GUID_ACTION GUID_ACTION
HL7_CODE_TABLE HL7 CODE_TABLE
HL7_CODE_TYPE_T£HL7_CODE_TYPE_T)

HL7_ERROR HL7_ERROR
IBOSSCHEMA_VERSIIBOSSCHEMA_VERS
ID_TABLE ID_TABLE

3. First set the Join Type to Left Outer.
4. Select DRLABEL as the table to join GRAPHICS to, if it is not already selected.
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Join GRAPHICS Table with

=] (A - |

GRAPHICS Fields DRLABEL Fields
PATHO SORTNO -
DATET HEADING Il

5. Select ADDR ID from the list of GRAPHICS fields on the left, and ADDR ID from the list of DRLABEL fields on the right.
6. Click the Add button if these two fields have been automatically added.

GRAPHICS Fields DRLABEL Fields

FATHO STATE ~
DATET ZIP

RELATEDTO PRACTICE MAME

DESCRIPTIONT Add MISCI

GRAPHICT ACTIVESTATUS

1] Bemove | ADDRID D
REFEREMCEID TAXOMNOMYID
m TYPEPROVIDER

FIELDSTR1 i

Joined Fields

GRAPHICS Field | Dperatar DRLABEL Field

GRAPHICS ADDR (D DRLABEL ADDR 1D

7. Click OK to close the window.

Adding the Signature Field
Now that we have the DRLABEL and GRAPHICS tables selected, we need to add the signature field to Selected Fields.

1. Inthe Query Designer window, click the Fields tab.
2. Click the Field Alias column title to sort the field names alphabetically.

[1] Query Designer. Register - ©
Tablesg l Figlds B Calcs |,o Search | kTd Group |?] Group S 4
Available Fields

Field Alias (&8 =z2) 1 Field SQL Alias | Table SOL Alias | ~
ADBRTT— RFGISTFR 1.4... RFGISTFR 1

3. Locate the GRAPHIC1 field in the list of available fields. This field stores the doctor's scanned signature.
4. Double-click to add it to the list of selected fields. If you cannot find it, it has already been added to selected fields.

5. If you would also like to add the provider's full printed name to the report, find the SIGNAME and double-click to add it to
the list of selected fields.

6. Click OK to close the Query Design window.

Adding the Signature to the Report

Now that the signature field has been set, it can be added to the report.

1. Return to the Design tab of the Office Practicum Report builder window to view the report.

Etham|ECalc & Design mPreview|
iIAEt&‘E@iE N =R
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If you do not see it, right click an empty space on the toolbar and make sure that Data Components is selected.

Advanced Components

Standard Components

Data Components

Report Tree

[l s

Data Tree

Align or Space
Size

MNudge

Draw

Edit

Standard

Format

3. Click the DBImage component button, and then click the location in the report where you want to add the signature.
Stretch the image box to an appropriate size, filling the space needed.

4. Next we need to set properties for the image. To do this, right-click the DBImage component and check the properties on
the popup menu listed below:

o DirectDraw makes the signature easier to read

o MaintainAspectRatio prevents the signature from looking stretched

o Stretch forces the image to shrink to fit in the space provided

o Transparent makes the background of the signature invisible instead of white, allowing for signing on lines

i

Bring Forward
Bring to Front
Send Backward
Send to Back

S T

AutoDisplay
AutoSize
Center

DirectDraw

[< 0] 1

GraphicType 2
MaintainAspectRatio

:[<]

Position...
ReprintOnOverFlow
Stretch

Transparent

Visible

< el

5. Next, select GRAPHIC1 from the edit combo-box on the toolbar.

GladdmBEe\MEEEIATDSBESSE®E B EH S HE

 Register -~ GRAPHIC1 » | Arial 210 =B L U |

6. If you'd like to add the provider's printed name:

a. Add a DBText component i3  to the report.
b. Select SIGNAME from the edit combo-box on the toolbar.
c. Right-click the DBText component you just added and selectAutoSize from the pop-up menu.
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7. This is what the components should like in Design mode after you've added them to the report:

[GRAPHICT] .

[GNAM

8. Save the report and close Design mode.

The signature should now appear when you preview and print the report.

s ingas

Demo Doctor, MD

n Note: If you need further assistance adding a signature to a report, please contacOffice Practicum Support.

Content provided by Dr. Suzanne Berman, MD of Plateau Pediatrics
Version 14.10

Note: Before adding a signature to a report, you will need to scan a signature and link it to a provider,
which is explained here.

Adding a Signature to a Report

Note: The steps below won't work for billing statement reports (found in the Billing_Rpts folder), chart reports, or
prescription reports. If you need a signature added to either of these types of reports, contact Office Practicum Support.

Joining the DRLABEL table

Before we can add a signature, we have to add the signature data field to selected fields.

1. Select Tools > OP Reports.

2. Locate the report where you would like to add a signature.
3. Right-click on the desired report and selectDesign mode.
4. Click the Data tab at the top of the window.

[ie]

! File Edit View Report Help

E Calc |55 Design | [, Preview

dl]lAa &A% @ E PN\ W

5. The window on the data tab represent database query. It controls which tables of the database are connected to the
report, and what fields on those tables are selected.
6. Click the SQL button.
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Register
RJOEB LT D )
Name [Type | sie |

7. Click the Tables tab to modify the tables selected for the report.

[R]

Tables EE:I Fields | [@ Cales |/~ Search | W Group | %) Group Search | % sort | (5 501 |
Available Tables

8. A Query Designer window will pop up displaying all of the tables used in Office Practicum. At the bottom of the window,
the selected tables are displayed. Look to see if the DRLABEL table is in the list of selected tables. If so, skip to the next
section. If not, we need to add it. Find the DRLABEL in the list of available tables.

RLABEL DRLABEL
K CATEGORY

DTN_CATEGORY_LIMDTM_CATEGORY_LII
DTM_DIAG_TEST_MDTM_DIAG_TEST_Mi
DTMN_LAB DTMN_LAB
DTM_MASTER_DETADTM_MASTER_DETA
DTM_OFL_DETAIL DTM_OFL_DETAIL
DTM_OP_FORM_LIS'DTM_OP_FORM_LIS
DTN_OP_FORM_LIS DTM_OP_FORM_LIS

Fay

Selected Tables
Table | Table Mame | SQL Alias Join Type
Register REGISTER. REGISTER._1

9. Double-click it to add it to selected tables. A Join Table window will appear.
10. Set the Join Type toLeft Outer.

Join Table

Join Type Join DRLABEL Table with

Left Outer [Register -
B Register Fields

SORTNO ~ PATND -

HEADING LNAME

SIGNAME FNAME

DRADD Add MI

TAXIDNO BIRTHDAT

FHOMENO Remave | |SEX

LICNO FORGFNM

DEANO PORGLNM

SERVNG e PORGMI e

loined Fields

DRLABEL Field Operator ~

DRLABEL.LNAME = REGISTER_LLNAME

DRLABEL. FNAME = REGISTER_L.FNAME

DRLABEL. ADDRESS = REGISTER_1.ADDRESS

DRLABEL,CITY = REGISTER_L.CITY w

< >
oK Cancel

11. Next, we need to set the table we are joining to. Choose the REGISTER table from the combo box.

Join DRLABEL Table with
IF‘.egister ;I

12. If applicable, remove all suggested joins from the Joined Fields list box by selecting them and clicking the
Remove button. These suggestions are usually not correct.
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Join Type:

Left Outer -

Join DRLABEL Table with

Register -

Register Fields

DRLABEL.ADDR ID

13. Alist of fields for the DRLABEL table appears on the left side of the window. LocateADDR ID from this list.

Join Type

IInner

DRLABEL Fields

=

PRACTICE MAME

Join UHLABEL | &DIe Wit

IRegister

=)

Register Fields

S ADDR.ID

TYPEPROVIDER B | PAT REF BY

FIELDSTR1 IMM REGISTRY QK

FIELDSTR2 PORTAL LOGIN

FIELDINT1 7 PORTAL PASSWORD ~
Joined Fields

14. Alist of fields for the joining table appears on the right side of the window. Select ADDR_ID.
15. Click the Add button to add it to the list of joined fields.

Join Type Join DRLABEL Table with

Jaener =l -
DRLABEL Fields Register Fields

PRACTICE NAME ~ DOD A
MISC1 VOID NOTE

ACTIVESTATUS ADDR ID

ADDR ID Add P ADDR ID

I TAXONOMYID S ADDR ID

I TYPEPROVIDER remove | [PATREFBY

FIELDSTR1 MM REGISTRY OK

FIELDSTR2 PORTAL LOGIN

FIELDINT L h PORTAL PASSWORD v
oined Fields

DRLABEL Field | Cperator

DRLABEL.ADDR ID = Register, ADDR ID

Cancel

o |

16. Click OK to close the window.
17. The DRLABEL table should now appear in the list of selected tables on the Query Designer window.

Joining the GRAPHICS table

Check if the GRAPHICS table is in the list of selected tables. If so, skip to the next section. If not, we need to add it.

1. Select the Tables tab in the Query Designer Window.
2. Find the GRAPHICS table in the list of available tables and double click to add it. A Join Table window will pop up.
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GET_MEW_SETRX ~ GET_NEW_SETRX
GETLABRESULTS  GETLABRESULTS
GLOBAL_PREFEREN( GLOBAL_PREFEREN
GROWTH_CHART ~ GROWTH_CHART
GROWTHCHART — GROWTHCHART
GROWTHCHART _LM GROWTHCHART _LIW
GUID_ACTION GUID_ACTION
HL7_CODE_TABLE HL7_CODE_TABLE
HL7_CODE_TYPE_T£HL7_CODE_TYPE_T)

HL7_ERROR HL7_ERROR
IBOSSCHEMA_VERSIIBOSSCHEMA_VERS
ID_TABLE ID_TABLE

3. First set the Join Type to Left Outer.
4. Select DRLABEL as the table to join GRAPHICS to, if it is not already selected.

Join GRAPHICS Table with

GRAPHICS Fields DRLABEL Fields
PATHO SORTNO -
DATET HEADING Il

5. Select ADDR ID from the list of GRAPHICS fields on the left, and ADDR ID from the list of DRLABEL fields on the right.
6. Click the Add button if these two fields have been automatically added.

GRAPHICS Fislds DRLABEL Fields
PATHO STATE "
DATET ZIP
RELATEDTO FRACTICE NAME
DESCRIFTIONT Add MISCT
GRAPHICT ACTIVESTATUS a
I} Remoyve ADDR D
REFERENCEID —l TA=ONOMYID
m TYPEPROYIDER
FIELDSTRI 2
Joined Fieldz
GRAPHICS Field | Operator DRLABEL Field
DRLABEL.ADDR ID

7. Click OK to close the window.

Adding the Signature Field

Now that we have the DRLABEL and GRAPHICS tables selected, we need to add the signature field to Selected Fields.

1. Inthe Query Designer window, click the Fields tab.
2. Click the Field Alias column title to sort the field names alphabetically.

[1] Query Designer. Register - ©
Tables ‘rr-im'_ Cales | 2 Search | "7 Group | ) Group Se: 4 »
Available Fields
Field Alias (&8 =z2) 1 Field SQL Alias | Table SOL Alias | ~
ARDHETT— RFGISTFR 1.A... RFGISTFR 1

3. Locate the GRAPHIC1 field in the list of available fields. This field stores the doctor's scanned signature.

4. Double-click to add it to the list of selected fields. If you cannot find it, it has already been added to selected fields.

5. If you would also like to add the provider's full printed name to the report, find the SIGNAME and double-click to add it to
the list of selected fields.

6. Click OK to close the Query Design window.

©
( p officepracticum.com | 800.218.9916 | 602 W. Office Center Drive, Suite 350, Fort Washington, PA 19034



-(Opw
Adding the Signature to the Report

Now that the signature field has been set, it can be added to the report.

1. Return to the Design tab of the Office Practicum Report builder window to view the report.

Etham|ECalc & Design mPreview|
Ik].a 3 té%a:ﬁ?\

2. To add the signature, we need to use the DBImage component seen below.

FEERCEN-=F Rl

N I N I

If you do not see it, right click an empty space on the toolbar and make sure that Data Components is selected.

Advanced Components

Standard Compeonents

Data Components

Report Tree
Data Tree

FIEIEEE

Align or Space
Size

MNudge

Draw

Edit

Standard

Format

3. Click the DBImage component button, and then click the location in the report where you want to add the signature.

Stretch the image box to an appropriate size, filling the space needed.
4. Next we need to set properties for the image. To do this, right-click the DBImage component and check the properties on
the popup menu listed below:

o DirectDraw makes the signature easier to read

¢ MaintainAspectRatio prevents the signature from looking stretched

o Stretch forces the image to shrink to fit in the space provided

o Transparent makes the background of the signature invisible instead of white, allowing for signing on lines
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Bring Forward
Bring to Front
Send Backward
Send to Back

T

AutoDisplay
AutoSize

Center

[< 0] 1

DirectDraw
GraphicType 2
MaintainAspectRatio

:[<]

Position...
ReprintOnOverFlow
Stretch

Bl

4444

Transparent

Visible

<]

5

5. Next, select GRAPHIC1 from the edit combo-box on the toolbar.

LlladawaadP\MEBAT B RE B 20 8- 2 H

i Register ~ GRAPHIC1 - |} Arial 10 | B Z U |

6. If you'd like to add the provider's printed name:

a. Add a DBText component i3 | to the report.

b. Select SIGNAME from the edit combo-box on the toolbar.
c. Right-click the DBText component you just added and selectAutoSize from the pop-up menu.

7. This is what the components should like in Design mode after you've added them to the report:

[GRAPHICT) .

IGNAME

8. Save the report and close Design mode.

The signature should now appear when you preview and print the report.

.&JW

Demao Doctor, MD

© If you need further assistance adding a signature to a report, please contactOffice Practicum Support.

Content provided by Dr. Suzanne Berman, MD of Plateau Pediatrics
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