We are currently updating the OP Help Center content for the release of OP 14.19 or OP 19. OP 19 is a member of the certified OP 14 family of products (official version is 14.19.1), which you may see in your software (such as in Help > About) and in the Help Center tabs labeled 14.19. You may also notice that the version number in content and videos may not match the version of your software, and some procedural content may not match the workflow in your software. We appreciate your patience and understanding as we make these enhancements.

Adding a Signature to a Report

Version 14.19
Note: Before adding a signature to a report, you will need to scan a signature and link it to a provider.

Adding a Signature to a Report

Note: The steps below won't work for billing statement reports (found in the Billing_Rpts folder), chart reports, or prescription reports. If you need a signature added to either of these types of reports, contact Office Practicum Support.

Joining the DRLABEL table

Before we can add a signature, we have to add the signature data field to selected fields.

  1. Select Tools > OP Reports.
  2. Locate the report where you would like to add a signature.
  3. Right-click on the desired report and select Design mode.
  4. Click the Data tab at the top of the window.

  1. The window on the data tab represent database query.  It controls which tables of the database are connected to the report, and what fields on those tables are selected.  
  2. Click the SQL button.

  1. Click the Tables tab to modify the tables selected for the report.

  1. A Query Designer window will pop up displaying all of the tables used in Office Practicum.  At the bottom of the window, the selected tables are displayed.  Look to see if the DRLABEL table is in the list of selected tables.  If so, skip to the next section.  If not, we need to add it.  Find the DRLABEL in the list of available tables.

  1. Double-click it to add it to selected tables.  A Join Table window will appear.  
  2. Set the Join Type to Left Outer

  1. Next, we need to set the table we are joining to.  Choose the REGISTER table from the combo box.

  1. If applicable, remove all suggested joins from the Joined Fields list box by selecting them and clicking the Remove button. These suggestions are usually not correct.

  1. A list of fields for the DRLABEL table appears on the left side of the window. Locate ADDR ID from this list.

  1. A list of fields for the joining table appears on the right side of the window.  Select ADDR_ID.  
  2. Click the Add button to add it to the list of joined fields.  

  1. Click OK to close the window.
  2. The DRLABEL table should now appear in the list of selected tables on the Query Designer window. 

Joining the GRAPHICS table

Check if the GRAPHICS table is in the list of selected tables.  If so, skip to the next section.  If not, we need to add it.  

  1. Select the Tables tab in the Query Designer Window.
  2. Find the GRAPHICS table in the list of available tables and double click to add it.  A Join Table window will pop up.  

  1. First set the Join Type to Left Outer.  
  2. Select DRLABEL as the table to join GRAPHICS to, if it is not already selected.

  1. Select ADDR ID  from the list of GRAPHICS fields on the left, and ADDR ID  from the list of DRLABEL fields on the right.  
  2. Click the Add button if these two fields have been automatically added. 

  1.  Click OK to close the window.

Adding the Signature Field

Now that we have the DRLABEL and GRAPHICS tables selected, we need to add the signature field to Selected Fields. 

  1. In the Query Designer window, click the Fields tab.  
  2. Click the Field Alias column title to sort the field names alphabetically.

  1. Locate the GRAPHIC1 field in the list of available fields.  This field stores the doctor's scanned signature.  
  2. Double-click to add it to the list of selected fields.  If you cannot find it, it has already been added to selected fields.  
  3. If you would also like to add the provider's full printed name to the report, find the SIGNAME and double-click to add it to the list of selected fields. 
  4. Click OK to close the Query Design window.

Adding the Signature to the Report

Now that the signature field has been set, it can be added to the report.

  1. Return to the Design tab of the Office Practicum Report builder window to view the report. 

  1. To add the signature, we need to use the DBImage component seen below.

  

If you do not see it, right click an empty space on the toolbar and make sure that Data Components is selected.

  1. Click the DBImage component button, and then click the location in the report where you want to add the signature.  Stretch the image box to an appropriate size, filling the space needed. 
  2. Next we need to set properties for the image.  To do this, right-click the DBImage component and check the properties on the popup menu listed below:
  • DirectDraw makes the signature easier to read
  • MaintainAspectRatio prevents the signature from looking stretched
  • Stretch forces the image to shrink to fit in the space provided
  • Transparent makes the background of the signature invisible instead of white, allowing for signing on lines

  1. Next, select GRAPHIC1 from the edit combo-box on the toolbar.

  1. If you'd like to add the provider's printed name:
  1. Add a DBText component to the report.  
  2. Select SIGNAME from the edit combo-box on the toolbar.  
  3. Right-click the DBText component you just added and select AutoSize from the pop-up menu.
  1. This is what the components should like in Design mode after you've added them to the report:


  1. Save the report and close Design mode.  

The signature should now appear when you preview and print the report.

If you need further assistance adding a signature to a report, please contact Office Practicum Support.

Content provided by Dr. Suzanne Berman, MD of Plateau Pediatrics

Version 14.10
Note: Before adding a signature to a report, you will need to scan a signature and link it to a provider, which is explained here.

Adding a Signature to a Report

Note: The steps below won't work for billing statement reports (found in the Billing_Rpts folder), chart reports, or prescription reports. If you need a signature added to either of these types of reports, contact Office Practicum Support.

Joining the DRLABEL table

Before we can add a signature, we have to add the signature data field to selected fields.

  1. Select Tools > OP Reports.
  2. Locate the report where you would like to add a signature.
  3. Right-click on the desired report and select Design mode.
  4. Click the Data tab at the top of the window.

  1. The window on the data tab represent database query.  It controls which tables of the database are connected to the report, and what fields on those tables are selected.  
  2. Click the SQL button.

  1. Click the Tables tab to modify the tables selected for the report.

  1. A Query Designer window will pop up displaying all of the tables used in Office Practicum.  At the bottom of the window, the selected tables are displayed.  Look to see if the DRLABEL table is in the list of selected tables.  If so, skip to the next section.  If not, we need to add it.  Find the DRLABEL in the list of available tables.

  1. Double-click it to add it to selected tables.  A Join Table window will appear.  
  2. Set the Join Type to Left Outer

  1. Next, we need to set the table we are joining to.  Choose the REGISTER table from the combo box.

  1. If applicable, remove all suggested joins from the Joined Fields list box by selecting them and clicking the Remove button. These suggestions are usually not correct.

  1. A list of fields for the DRLABEL table appears on the left side of the window. Locate ADDR ID from this list.

  1. A list of fields for the joining table appears on the right side of the window.  Select ADDR_ID.  
  2. Click the Add button to add it to the list of joined fields.  

  1. Click OK to close the window.
  2. The DRLABEL table should now appear in the list of selected tables on the Query Designer window. 

Joining the GRAPHICS table

Check if the GRAPHICS table is in the list of selected tables.  If so, skip to the next section.  If not, we need to add it.  

  1. Select the Tables tab in the Query Designer Window.
  2. Find the GRAPHICS table in the list of available tables and double click to add it.  A Join Table window will pop up.  

  1. First set the Join Type to Left Outer.  
  2. Select DRLABEL as the table to join GRAPHICS to, if it is not already selected.

  1. Select ADDR ID  from the list of GRAPHICS fields on the left, and ADDR ID  from the list of DRLABEL fields on the right.  
  2. Click the Add button if these two fields have been automatically added. 

  1.  Click OK to close the window.

Adding the Signature Field

Now that we have the DRLABEL and GRAPHICS tables selected, we need to add the signature field to Selected Fields. 

  1. In the Query Designer window, click the Fields tab.  
  2. Click the Field Alias column title to sort the field names alphabetically.

  1. Locate the GRAPHIC1 field in the list of available fields.  This field stores the doctor's scanned signature.  
  2. Double-click to add it to the list of selected fields.  If you cannot find it, it has already been added to selected fields.  
  3. If you would also like to add the provider's full printed name to the report, find the SIGNAME and double-click to add it to the list of selected fields. 
  4. Click OK to close the Query Design window.

Adding the Signature to the Report

Now that the signature field has been set, it can be added to the report.

  1. Return to the Design tab of the Office Practicum Report builder window to view the report. 

  1. To add the signature, we need to use the DBImage component seen below.

  

If you do not see it, right click an empty space on the toolbar and make sure that Data Components is selected.

  1. Click the DBImage component button, and then click the location in the report where you want to add the signature.  Stretch the image box to an appropriate size, filling the space needed. 
  2. Next we need to set properties for the image.  To do this, right-click the DBImage component and check the properties on the popup menu listed below:
  • DirectDraw makes the signature easier to read
  • MaintainAspectRatio prevents the signature from looking stretched
  • Stretch forces the image to shrink to fit in the space provided
  • Transparent makes the background of the signature invisible instead of white, allowing for signing on lines

  1. Next, select GRAPHIC1 from the edit combo-box on the toolbar.

  1. If you'd like to add the provider's printed name:
  1. Add a DBText component to the report.  
  2. Select SIGNAME from the edit combo-box on the toolbar.  
  3. Right-click the DBText component you just added and select AutoSize from the pop-up menu.
  1. This is what the components should like in Design mode after you've added them to the report:


  1. Save the report and close Design mode.  

The signature should now appear when you preview and print the report.

If you need further assistance adding a signature to a report, please contact Office Practicum Support.

Content provided by Dr. Suzanne Berman, MD of Plateau Pediatrics