Important Content Update Message
We are currently updating the OP Help Center content for the release of OP 20. OP 20 (official version 20.0.x) is the certified, 2015 Edition, version of the Office Practicum software. This is displayed in your software (Help tab > About) and in the Help Center tab labeled Version 20.0. We appreciate your patience as we continue to update all of our content.

OP Database Viewer

Version 14.19

About OP Database Viewer

Path: Tools tab > Database Viewer button
For a PDF version of the Database Viewer Quick Reference Guide, click here.

The OP Database Viewer functions as a database viewer and SQL query tool.  The OP Database Viewer allows you to run, save, and export data within the database viewer to quickly provide all the data necessary based on a query.

Note: The Database Viewer accesses the same database as OP.  If you run a query that filters a lot of data, your database could become sluggish and affect your users.  It is recommended to run queries during hours when users are not running OP. 

OP Database Viewer Map

Number
SectionDescription

1

Table List panelThe Table List panel contains all the available database tables found in the OP software.

2

Table Data panelThe Table Data panel displays all the data for the selected database table.

3

Fields tabThe Fields tab lists the data contained within each selected database table.

4

Data Grid tabThe Data Grid tab lists the data contained within each selected database table.

5

Data Details tabThe Data Details tab lists the details for each selected line in the Data Grid tab.

6

Find by Name/Description tabThe Find by Name/Description tab searches for a particular data element.

7

SQL tabThe SQL tab groups particular elements from the database table based on the selected query.  You can create, run, and export queries in this tab. Query results are exported as a .csv file, which can be opened in Excel. Created queries can also be selected in the SQL Jobs tab.

8

SQL Jobs tabThe SQL Jobs tab groups multiple queries (created in the SQL tab) into jobs. Jobs create multiple .csv files in a particular folder. You can create, run, export, and import SQL Jobs using this tab.
Version 14.10

About OP Database Viewer

Path: Tools Menu > Database Viewer (Keyboard Shortcut keys: [Alt][T][D])
For a PDF version of the Database Viewer Quick Reference Guide, click here.

The OP Database Viewer functions as a database viewer and SQL query tool.  The OP Database Viewer allows you to run, save, and export data within the database viewer to quickly provide all the OP 14 data necessary based on a query.

Note: The Database Viewer accesses the same database as OP.  If you run a query that filters a lot of data, your database could become sluggish and affect your users.  It is recommended to run queries during hours when users are not running OP. 

OP Database Viewer Map

Number
SectionDescription

1

Table List panelThe Table List panel contains all the available database tables found in OP 14.

2

Table Data panelThe Table Data panel displays all the data for the selected database table.

3

Fields tabThe Fields tab lists the data contained within each selected database table.

4

Data Grid tabThe Data Grid tab lists the data contained within each selected database table.

5

Data Details tabThe Data Details tab lists the details for each selected line in the Data Grid tab.

6

Find by Name/Description tabThe Find by Name/Description tab searches for a particular data element.

7

SQL tabThe SQL tab groups particular elements from the database table based on the selected query.  You can create, run, and export queries in this tab. Query results are exported as a .csv file, which can be opened in Excel. Created queries can also be selected in the SQL Jobs tab.

8

SQL Jobs tabThe SQL Jobs tab groups multiple queries (created in the SQL tab) into jobs. Jobs create multiple .csv files in a particular folder. You can create, run, export, and import SQL Jobs using this tab.